Dell R410安装Ubuntu无法启动解决方法

2011年4月9日 | 分类: Linux | 标签: , , , , ,

       今天用Dell R410网络安装了一下Ubuntu 10.04,重新启动后无法进入系统,提示什么“Gave up waiting for root device.”,“- Check rootdelay”,“- Missing modules”等等,如下图:

 

在网上搜了一下,找到一篇文章,原文地址如下:

http://stoilis.wordpress.com/2009/11/20/error-on-first-boot-after-installing-ubuntu-on-a-dell-r410/

大概意思是说由于Dell的SAS Controller没有来得及装载成功就开始引导系统了,导致找不到磁盘驱动器系统启动失败。他的系统加载SAS Controller需要35秒,可以修改grup,延迟启动35秒就可以了。人家都搞定了,咱就照着做呗:

1.机器硬件检测完网卡和DRAC以后一直按住Shift键,直到加载完GRUB菜单;

 

2.选择e来编辑GRUB;

 

3.原文说找到kernel command line,添加“rootdelay=35”;我就蒙了,木有啊,我就又找了篇文章,从里边找到了需要的东西,原来是在下边这个位置加:

http://skyyan.wordpress.com/2010/12/19/first-boot-error-after-installing-ubuntu-10-04-on-dell-r410/

 

4.按”Ctrl+x”启动系统,好使了,不过这还没完;

5.进入系统后,需要修改GRUB,彻底解决问题,第一篇文章说的修改“/boot/grub/menu.lst”,这是GRUB的配置文件,从Ubuntu 9.10开始,使用GRUB 2作为默认的引导和管理启动程序,需要修改”/etc/default/grub”,还是修改rootdelay,如下图:

 

6.sudo update-grup    #保存修改的grub配置文件;

这里我又遇到麻烦了,我的系统提示我找不到这个命令,头大,继续找呗,又找到下边的文章:https://help.ubuntu.com/community/Grub2

这个命令在grup-pc的包里边,用命令安装一下:

sudo apt-get install grup-pc

然后再执行命令,重启,搞定。

Written by an6097

  1. lixi
    2011年4月27日15:58

    可以啊!!今天我就遇上了,这个愁,结果让韬哥搞定啦~还是祖师爷牛逼啊~~

  2. 2011年4月27日16:29

    @lixi
    呵呵,欢迎常来交流啊… :)

    • lixi
      2011年4月27日16:30

      好的好的,磊哥V5啊~

  3. lion
    2011年4月27日17:41

    哈哈哈哈

  4. ai
    2012年11月3日22:40

    早点找到我就不用话了9个小时后,再去安装centos 了

    我这里是使用ssd硬盘为系统盘,后面两个硬盘数据盘,

    希望以后有这样的经历的朋友找到这个答案吧

注意: 评论者允许使用'@user空格'的方式将自己的评论通知另外评论者。例如, ABC是本文的评论者之一,则使用'@ABC '(不包括单引号)将会自动将您的评论发送给ABC。使用'@all ',将会将评论发送给之前所有其它评论者。请务必注意user必须和评论者名相匹配(大小写一致)。